Urgent maintenance planned on mail servers (possible email downtime)
Scheduled for February 26, 2026 at 10:00 PM – February 27, 2026 at 1:00 AM
Affects
Mail servers
Under maintenance from 10:00 PM to 1:00 AM
Completed
February 27, 2026 at 1:00 AMCompleted
February 27, 2026 at 1:00 AMMaintenance has completed successfully
In progress
February 26, 2026 at 10:00 PMIn progress
February 26, 2026 at 10:00 PMMaintenance is now in progress
Planned
February 26, 2026 at 10:00 PMPlanned
February 26, 2026 at 10:00 PMThis evening at 23:00, we will perform urgent maintenance on our mail infrastructure.
Affected systems:
Mail servers: 001, 002, 003, 004, 005
spamfilter1 and spamfilter2
Webmail
Expected impact:
Possible downtime of up to 1 hour in total (we expect it to be significantly less)
During the downtime, sending and receiving email may be unavailable
We apologize for the inconvenience and appreciate your understanding.