Issues with our websites

Resolved
Major outage
Started 6 months ago Lasted 25 minutes

Affected

Site websites
Site.nl
Site.be
Site.de
Site.fr
Site.es
Updates
  • Resolved
    Update

    Unfortunately, our website are again unavailable. We are investigating what the reason could be.

  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We regret to inform you that our company websites are currently experiencing technical difficulties. At this time, users are unable to log into their dashboards, manage domain names, or place orders for new domain names. We understand the importance of these functionalities to our users, and we are actively investigating the root cause of the issue.