Mailserver down

Resolved
Partial outage
Started 7 months ago Lasted 22 minutes

Affected

Mail servers
Mail001
Mail002
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We wish to inform you that our central mail server is currently down. The downtime occurred post the routine updates that we conduct on our systems. Our technical team is actively working on resolving the issue and restoring the service as soon as possible. Users may experience delays in receiving emails, and some functionalities related to email services might be temporarily unavailable. It is currently not possible to send or fetch emails from the mail server. Please be assured that no emails will be lost during this downtime. All emails will be queued and delivered once the service is restored.