Mailserver issues

Resolved
Degraded performance
Started about 1 year ago Lasted about 8 hours

Affected

Mail servers
Mail001
Mail002
Updates
  • Resolved
    Resolved

    Our team has successfully implemented the fix, and our systems have been operating normally since we implemented the fix earlier this afternoon.

  • Monitoring
    Update

    We implemented a fix and are currently monitoring the result.

  • Monitoring
    Monitoring

    We regret to inform you that we are currently experiencing some issues with our mailserver due to a bruteforce attack. Our team is actively working to block these malicious requests and resolve the issue as soon as possible. However, as a result, you may experience some unresponsiveness or slow performance from the mailserver. We apologize for any inconvenience this may cause and appreciate your patience as we work to resolve the issue. Rest assured that we are taking all necessary measures to ensure the security and stability of our systems. We will continue to provide updates on our progress and expect to have the issue resolved soon.